[SOLVED]: Node Sass version 5.0.0 is incompatible

When you get this Error: Node Sass version 5.0.0 is incompatible with 4.0.0 while trying to run your application, here is a possible solution to it.

Workaround: don't install node-sass 5.0.0 yet (major version was just bumped).

Uninstall node-sass

npm uninstall node-sass

Then install the latest version (before 5.0)

npm install node-sass@4.14.1

This is the solution that currently works